您当前位于: 首页 » zend studio不知道 » 往zend studio 7中安装可视化所见即所得编辑器

往zend studio 7中安装可视化所见即所得编辑器11/16/2009

以前的一篇文章中我说zend studio 7 已经去除了所见即所得的可视化html编辑器,而这个在6.x的时候为不少开发者(至少中国的开发者)追捧的如痴如醉一大特色功能,由于颇占用资源而被zend官方果断的阉割了。今天我们打算找回这段在历史长河的某个角落遗落的小JJ。这个插件的作用就是像Dreamweaver或者FrontPage那样的可视化编辑html文件,就是用鼠标拖来拖去就可以搞个网页出来的,她的学名叫做WYSIWYG EDITOR(所见即所得编辑器),而实际上,我们在上一篇文章关于怎样安装aptana插件的叙述中,aptana同样具有很好的html可视化编辑能力,而且安装本插件你需要先卸载掉aptana,因为他们有冲突。好吧,我们开始!

通过菜单Help -> Install New Software,打开Install对话框。在work with处粘贴https://download.eclipse.org/releases/galileo,在filter中输入web来过滤多余的插件列表,最后勾选Web Page Editor单击next进入下一步,如下图:

wyiswyg1
图1

然后继续Next….(图2)

wyiswyg2
图2

同意协议(图3)

wyiswyg3
图3

正在下载WYSIWYG Editor安装ing…(图4)

wyiswyg4
图4

安装完毕,需要重启zend studio(图5)

wyiswyg5
图5

重启完了,右键菜单中找到Web Page Editor(图6)

wyiswyg6
图6

在上图中惊现aptana,所以上面那个文件实际上没有打开成功,我重新截图了,这是可视化编辑html时候的样子(图7)

wyiswyg7
图7

OK,就是这样,可视化编辑的强大功能也融合了进来了,希望您不要把zend studio当成Dreamweaver来用咯~

| 5条评论 标签:  

5条评论
  1. bbssw说道:

    唉可惜和aptana冲突

  2. onlywww说道:

    请问下如果编辑.php文件是不是可以用这个功能呢?还有.php里包含js代码的时候是不是可以启用aptana的代码提示功能?
    zend studio里的每个编辑器(WYSIWYG Editor和aptana)是不是只能完成单独完成自己的功能
    就好像我编辑文件的时候 在一个.php文件里要写点html代码js代码php是不是可以来回切换编辑器而不用用另一个编辑器打开文件呢?
    上面意思说得有点乱 其实我就是想知道编辑器功能可不可以混用

    • gently说道:

      似乎你的需求太过特殊啊,呵呵,实际工作中是很少将html和php混到一起写的,当然学习中无可厚非,如果你喜欢这样,建议你用dw。

  3. 提问说道:

    zend studio 9.0.4安装不了,出现以下错误,该怎么办?
    Cannot complete the install because of a conflicting dependency.
    Software being installed: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
    Software currently installed: Zend Studio 9.0.2.v20120229413 (com.zend.php.ide 9.0.2.v20120229413)
    Only one of the following can be installed at once:
    Structured Source Editor 1.3.1.v20120228 (org.eclipse.wst.sse.ui 1.3.1.v20120228)
    Structured Source Editor 1.1.102.v200910200227 (org.eclipse.wst.sse.ui 1.1.102.v200910200227)
    Structured Source Editor 1.3.2.v201206281501 (org.eclipse.wst.sse.ui 1.3.2.v201206281501)
    Structured Source Editor 1.1.101.v200908261807 (org.eclipse.wst.sse.ui 1.1.101.v200908261807)
    Structured Source Editor 1.3.2.v201201041522 (org.eclipse.wst.sse.ui 1.3.2.v201201041522)
    Cannot satisfy dependency:
    From: Zend Studio 9.0.2.v20120229413 (com.zend.php.ide 9.0.2.v20120229413)
    To: com.zend.php.patches.feature.group [9.0.2.v20120228]
    Cannot satisfy dependency:
    From: Zend Studio 9.0.2.v20120229413 (com.zend.php.ide 9.0.2.v20120229413)
    To: org.eclipse.wst.web_ui.feature.feature.group [3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL]
    Cannot satisfy dependency:
    From: Zend Studio Patches Feature 9.0.2.v20120228 (com.zend.php.patches.feature.group 9.0.2.v20120228)
    To: org.eclipse.wst.xml_ui.feature.patch.feature.group [1.0.0.v20120228]
    Cannot satisfy dependency:
    From: JavaServer Faces Tools – Web Page Editor 1.2.3.v20100211 (org.eclipse.jst.pagedesigner 1.2.3.v20100211)
    To: bundle org.eclipse.wst.sse.ui [1.0.101,1.3.0)
    Cannot satisfy dependency:
    From: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
    To: org.eclipse.jst.pagedesigner [1.2.3.v20100211]
    Cannot satisfy dependency:
    From: Eclipse Web Developer Tools 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL (org.eclipse.wst.web_ui.feature.feature.group 3.3.1.v201107072200-7O7IFhREMiB5vNoYqf01XHTvUndyz-yx-9kUyXXL)
    To: org.eclipse.wst.xml_ui.feature.feature.group [3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL]
    Cannot satisfy dependency:
    From Patch: org.eclipse.wst.xml_ui.feature.patch.feature.group 1.0.0.v20120228 Eclipse XML Editors and Tools 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL (org.eclipse.wst.xml_ui.feature.feature.group 3.3.1.v201108102009-7H7EFZ3DxumTlaI6nheRdHo2p1KaDIL1Uz-S3PL)
    To: org.eclipse.wst.sse.ui [1.3.1.v20120228]

  4. laocui172说道:

    zend studio 10.6.2无法安装,提示如下

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
    Software currently installed: Zend Studio 10.6.2.v20140121-20140605-0147-212 (com.zend.php.ide 10.6.2.v20140121-20140605-0147-212)
    Only one of the following can be installed at once:
    Common URI Resolver Framework 1.1.301.v200805140415 (org.eclipse.wst.common.uriresolver 1.1.301.v200805140415)
    Common URI Resolver Framework 1.2.0.v201203071939 (org.eclipse.wst.common.uriresolver 1.2.0.v201203071939)
    Cannot satisfy dependency:
    From: Zend Studio 10.6.2.v20140121-20140605-0147-212 (com.zend.php.ide 10.6.2.v20140121-20140605-0147-212)
    To: org.eclipse.wst.web_ui.feature.feature.group [3.4.2.v201211061806-7O7MFu3EMkBK01NbrfU9ATE5cdZFz-OoeYjaI4d2]
    Cannot satisfy dependency:
    From: Zend Studio 10.6.2.v20140121-20140605-0147-212 (com.zend.php.ide 10.6.2.v20140121-20140605-0147-212)
    To: org.eclipse.wst.web_ui.feature.patch.feature.group [1.0.0.v201305221835]
    Cannot satisfy dependency:
    From: JavaServer Faces Tools – Web Page Editor 1.2.3.v20100211 (org.eclipse.jst.pagedesigner 1.2.3.v20100211)
    To: bundle org.eclipse.wst.common.uriresolver [1.1.0,1.2.0)
    Cannot satisfy dependency:
    From: Web Page Editor (Optional) 2.2.2.v201001271707-43799oB5855B7A2242 (org.eclipse.jst.webpageeditor.feature.feature.group 2.2.2.v201001271707-43799oB5855B7A2242)
    To: org.eclipse.jst.pagedesigner [1.2.3.v20100211]
    Cannot satisfy dependency:
    From: JSDT Web Support UI 1.0.502.v201305221835 (org.eclipse.wst.jsdt.web.ui 1.0.502.v201305221835)
    To: bundle org.eclipse.wst.common.uriresolver [1.2.0,2.0.0)
    Cannot satisfy dependency:
    From Patch: org.eclipse.wst.web_ui.feature.patch.feature.group 1.0.0.v201305221835 Eclipse Web Developer Tools 3.4.2.v201211061806-7O7MFu3EMkBK01NbrfU9ATE5cdZFz-OoeYjaI4d2 (org.eclipse.wst.web_ui.feature.feature.group 3.4.2.v201211061806-7O7MFu3EMkBK01NbrfU9ATE5cdZFz-OoeYjaI4d2)
    To: org.eclipse.wst.jsdt.web.ui [1.0.502.v201305221835]

发表评论